紧急扩散:Linux系统bash严重安全漏洞CVE-2014-6271的检测及修复方法

今天白天,重量网络在群里提醒我,说 Linux 出现了严重的 bash 漏洞,一直在忙也没怎么关注,晚上空闲看了下,发现确实非常严重,必须紧急扩散出去,防止服务器被黑客入群,造成严重的后果!

紧急扩散:Linux系统bash严重安全漏洞CVE-2014-6271的检测及修复方法

9 月 25 日消息,继“心脏流血”漏洞之后,安全研究专家又发现了一个危险级别为“毁灭级”(catastrophic)的漏洞,开源软件公司 Red Hat 在一份报告中称,在 Linux 系统中广泛使用的 Bash 软件漏洞有可能让黑客利用攻击一切连入互联网的设备。

该漏洞编号为 CVE-2014-6271,主要存在于 bash 1.14 - 4.3 版本中,受影响的 linux 系统包括:Red Hat 企业 Linux (versions 4 ~7) 、Fedora distribution、CentOS (versions 5 ~7)、Ubuntu 10.04 LTS,12.04 LTS 和 14.04 LTS、Debian 等。

 受影响的软件及系统:GNU Bash <= 4.3

GNU Bash 4.3 及之前版本在处理某些构造的环境变量时存在安全漏洞,向环境变量值内的函数定义后添加多余的字符串会触发此漏洞,攻击者可利用此漏洞改变或绕过环境限制,以执行 shell 命令。 漏洞可以直接在 Bash 支持的 Web CGI 环境下远程执行任意命令!一些路由器、堡垒机、VPN 等网络设备也可能会受到影响.当 cgi 程序里需要创建子进程,且环境变量可控时,攻击者可以通过 useragent,querystring 等 http 特性构造恶意攻击代码进行远程攻击,可能直接导致服务器被恶意控制,从而导致数据存在泄露的风险。

美国国土安全部下属的美国电脑紧急响应团队(以下简称“US-CERT”)发出警告称,这一漏洞可能影响基于 Unix 的操作系统,包括 Linux 和 Mac OS X。

漏洞详情页面:http://seclists.org/oss-sec/2014/q3/650

漏洞级别:非常严重

RedHat 官方提供漏洞详情:

A flaw was found in the way Bash evaluated certain specially crafted environment variables. An attacker could use this flaw to override or bypass environment restrictions to execute shell commands. Certain services and applications allow remote unauthenticated attackers to provide environment variables, allowing them to exploit this issue.

RedHat 官方提供的检测方式:

登录终端,运行如下命令:

如果返回以下内容:表示存在次漏洞,则请尽快升级。

紧急扩散:Linux系统bash严重安全漏洞CVE-2014-6271的检测及修复方法

目前官方已经提供了升级包请执行如下命令进行升级处理:

紧急扩散:Linux系统bash严重安全漏洞CVE-2014-6271的检测及修复方法

升级后,再一次执行前面的命令进行检测,若出现如下信息,则表示已修复:

紧急扩散:Linux系统bash严重安全漏洞CVE-2014-6271的检测及修复方法

而 Ubuntu 用户则可以通过如下命令升级 bash:

其他 Linux 发行版,没有在线安装功能的,请使用以下脚本编译安装 bash 漏洞补丁:

漏洞是否修复成功的检测方法与前文一样。另外,有人提到升级后是否需要重启服务器?其实是不需要的,只要通过漏洞检测即可。当然,你要不放心,重启下也是可以的。。。

此次漏洞很严重,请看到此消息的朋友互相宣传扩散,谨防此漏洞带来任何损失。

最新补充:已更新最新的漏洞情况及修复检测方法,请移步==>

评论已关闭!